Aquascapes pump RIP.

Discussion in 'Pond Construction & Equipment' started by Mike T., Jul 22, 2013.

  1. Mike T.

    Mike T.

    Joined:
    Jul 22, 2013
    Messages:
    2
    Likes Received:
    5
    Location:
    Ontario Canada.
    I've had an Aquascapes pump in my pondless waterfall for three years and ten months (it had a 3-year warranty). With it being a pump for a pondless waterfall it only gets used 6 months of the year and for about 12 hours daily. Last week it just quit on me. I took it apart and found the ceramic impeller shaft had broken. I phoned Aquascapes and sent in some pics of the problem. Today I got an e-mail from Ryan in the tech services department. It said -

    "We are not able to get the part you need. Unfortunately you will need to replace the pump."

    This was an Aquascapes AS 2000 pump that cost me $330 up here in Canada. It's less than four years old and they don't stock parts for it? It's a throw-away pump? Sorry Aquascapes but that's not good enough. Your customer service and committment is disgusting. My pump has now been replaced with a Laguna and my dealer claims he's gotten spare parts for ten year old pumps.

    Next I'll take a drive to my local Aquascapes dealer and tell him my findings.
     
    Mike T., Jul 22, 2013
    #1
    addy1, HARO and Mmathis like this.
    1. Advertisements

  2. Mike T.

    slakker AKA Mike

    Joined:
    Mar 20, 2012
    Messages:
    351
    Likes Received:
    321
    Location:
    Vancouver, Canada
    That sucks... good to know as I was wondering what pump to use if the one I have goes... I'm actually using a eheim pump from my salt reef setup, and they're pretty bullet proof in the reefing community.
     
    slakker, Jul 23, 2013
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.