Fishmate leaking hose tail connectors


Joined
Sep 17, 2020
Messages
1
Reaction score
0
Country
United Kingdom
Hi, I am building a 5000 litre pond right now and purchased a fishmate 15000 filter. I noticed the hose tail connectors didn't come with any o-ring unlike my UV filter and pump and there does not seem to be any space to fit one either. When I plumbed it in and tightened it up it leaked badly on both the inlet and outlet. Even PVC plumbers tape around the collar and a jubilee clip for good measure hasn't stopped the leak completely. Is this a known issue with the Fishmate connectors and is there a way of getting a non leaky connection? Any tips or advice greatly appreciated!
 
Ad

Advertisements

TheFishGuy

( Insert something funny )
Joined
Jul 9, 2020
Messages
753
Reaction score
409
Location
Colorado
Showcase(s):
1
Hardiness Zone
4b or 5a
Country
United States
not sure how to answer your question, I would say a bead of silicone, but I have no experience with those connectors so dont know what they look like or what they are for.

although, Welcome to the forum!
 
Joined
Jul 12, 2009
Messages
2,556
Reaction score
1,567
Location
Mount Pocono, Pennsylvania
Hardiness Zone
6a
Not exactly sure what you have there. Are they hose barb connectors that screw into your pump? I guess you mean they are leaking from the threaded side. Try wrapping a few layers of plumber's teflon tape on the threads before you screw them in.
Post some pictures if you can.
 
Ad

Advertisements

Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top