Help !! Pond pump stopped


Joined
Apr 10, 2020
Messages
44
Reaction score
17
Country
United Kingdom
Hi
Pond is 308 gallons Atlantis windsor
Pump Hozelock 9000 stopped dead today
Have 14 rescue goldfish
Put an airstone in pond, and not feeding
New pump ordered Amazon Prime
Have put an airstone in, but how long will fish be Ok without filtration ?? xx
 
Ad

Advertisements

sissy

sissy
Joined
Jan 17, 2011
Messages
32,745
Reaction score
15,376
Location
Axton virginia
Showcase(s):
1
Hardiness Zone
7A
Country
United States
as long as not fed and water temperature is not to high for a week or more .Main reason I always use 2 pumps in my pond .Had that happen to me but I did find a dirty water pump and used that .But good stuff in the filter may die
 
Joined
Apr 10, 2020
Messages
44
Reaction score
17
Country
United Kingdom
as long as not fed and water temperature is not to high for a week or more .Main reason I always use 2 pumps in my pond .Had that happen to me but I did find a dirty water pump and used that .But good stuff in the filter may die
 
Joined
Apr 10, 2020
Messages
44
Reaction score
17
Country
United Kingdom
Thank you
I rescued the fish , and really dont want them to die on me
New pump on order from Amazon prime so should come tomoz
Never had this happen before
Big stress !! xx
 

sissy

sissy
Joined
Jan 17, 2011
Messages
32,745
Reaction score
15,376
Location
Axton virginia
Showcase(s):
1
Hardiness Zone
7A
Country
United States
did you check the impeller on your pump and clean it .Most have a magnetic shaft that some gravel gets behind and did you check your circuit breaker
 
Ad

Advertisements

Joined
May 27, 2020
Messages
10
Reaction score
3
Location
Norfolk, England
Showcase(s):
1
Hardiness Zone
Very
Country
United Kingdom
Hello, All I can recommend is first check your power supply , wiring, fuse ect.. then pull your pump out of your pond remove cover and filter then check your Impeller. Goodluck
 
Joined
Apr 10, 2020
Messages
44
Reaction score
17
Country
United Kingdom
Man coming in the am to give it the once over
Very new to this but second time around
Never had these issues before when had a pond xx
 
Joined
Apr 10, 2020
Messages
44
Reaction score
17
Country
United Kingdom
Hello, All I can recommend is first check your power supply , wiring, fuse ect.. then pull your pump out of your pond remove cover and filter then check your Impeller. Goodluck
Hi Rob
Yes doing all that today xx
 
Ad

Advertisements

Joined
Mar 12, 2012
Messages
179
Reaction score
100
Location
Cincinnati
my old pump would lock up in the last few years of service. There wasn't anything physically stopping the impeller... it just needed a "jump"... which for me meant literally waking the whole pump with a stick ... and it would start back up.
 

sissy

sissy
Joined
Jan 17, 2011
Messages
32,745
Reaction score
15,376
Location
Axton virginia
Showcase(s):
1
Hardiness Zone
7A
Country
United States
how old is the pup because I have had laguna pumps since 2004
 
Ad

Advertisements

Joined
Apr 10, 2020
Messages
44
Reaction score
17
Country
United Kingdom
my old pump would lock up in the last few years of service. There wasn't anything physically stopping the impeller... it just needed a "jump"... which for me meant literally waking the whole pump with a stick ... and it would start back up.
Thank you
Am about to take it all apart
New pump from Amazon prime as 1 day delivery
Pump was only working for 3 months
Not impressed with Hozelock !! xx
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top