How to check UV light working?


Joined
Aug 2, 2015
Messages
8
Reaction score
1
Location
Connecticut
Country
United States
Before re-installing my UV filter this year (for Savio skimmer), I decided to check that it was working OK. After putting on UV protective glasses, I plugged the unit in and looked at the bulb, and saw nothing. After disconnecting the bulb, I tried to check that power was reaching it, using a multimeter. There are 4 terminals that connect the bulb to power supply (Emperor, see pic), but I could only check 2 at a time - so probably not reliable (0.2 V AC only). I thought that the transformer would be a reliable part of the setup. Anyone have any experience with what it likely to fail with this system?
Thanks.
 

Attachments

Ad

Advertisements

Joined
Jun 8, 2016
Messages
3,005
Reaction score
2,872
Hardiness Zone
5b
Country
United States
Did you use a new light bulb?
 
Joined
Aug 2, 2015
Messages
8
Reaction score
1
Location
Connecticut
Country
United States
Did you use a new light bulb?
Thanks Gemma. The bulb is part of the dilemma, it was new last year, although I admit I did not check it before using. Getting a new bulb might be the reasonable decision, as I will need one at some time anyway, and if the new bulb doesn't work then it must be the power supply. Actually found out that the power supply is a ballast, not a transformer as I had thought.
 
Ad

Advertisements

Joined
Sep 14, 2013
Messages
4,664
Reaction score
3,603
Location
Cincinnati, Ohio
Hardiness Zone
6 A
Country
United States
I have a Savio UV too, that slides into the skimmer. I find I get two seasons from the bulb, before it becomes ineffective. I'd try a new bulb :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top