dead fish


carmel

Carmel
Joined
Jul 29, 2013
Messages
14
Reaction score
5
Location
Peterborough, On
Hardiness Zone
5A
Country
i am so upset...yesterday we pulled the leaf net off the top of the pond and reset the pond bubbler...everything seemed to be fine..we could see a couple fish (koi) down low....today i went out to find 2 dead and two more near the top, its cold here...around 0 celcius and we have some snow. they shouldnt be up swimming around should they?? and what would have caused the deaths?? us taking the leaf net off maybe?? i lost all them last year because we have a flash freeze and i dint have the bubbler in in time....
 
Ad

Advertisements

Joined
Jun 8, 2016
Messages
2,816
Reaction score
2,679
Hardiness Zone
5b
Country
So sorry you lost your fish:(
I doubt the cold is to blame, something is obviously going on with your setting so please listen to @MitchM , give all the info necessary so he/others can help you figure out what the problem is, and you can stop losing fish
 
Ad

Advertisements

carmel

Carmel
Joined
Jul 29, 2013
Messages
14
Reaction score
5
Location
Peterborough, On
Hardiness Zone
5A
Country
Hi carmel,
We need to know details about your pond setup, size, filtration, maintenance routine, numerical water test results and stocking levels first.
HI...its a 2000 gallon pond, sicce 40 with ultra violet lite. i used pond balance in the summer and no issues with algea, backwashed every other week. all seemed fine until we disturbed the fish by pulling the leaf cover off and the water sloshed around, it was the next day i found the fish.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top